matthewfry
Navigator

FAM Automatic Services not starting

Jump to solution

Has anyone else noticed that many of the FAM services that are set to automatic don't actually automatically start?  We had patching over the weekend, and I logged on this morning to find many of my services as being down.  I had to go and manually start them.... and this isn't a one time thing, it happens almost everytime after the servers are rebooted.

0 Kudos
Reply
1 Solution

Accepted Solutions
matthewfry
Navigator

By the way everyone, I discovered the issue here.  Windows has a default setting in the registry where if a service takes longer than 30 seconds to start, it will error out.  Well, these services are taking longer than 30 seconds to start.  I changed that default setting in the registry to 180 seconds, and now my services start up automatically without isse.

I am a bit curious why it takes so long for these services to start though.

View solution in original post

0 Kudos
Reply
7 Replies
ruben_elizondo
SailPoint Employee
SailPoint Employee

I have not noticed that being a consistent problem, most of the services are set to delayed start to default though. I would try to adjust the services to delayed start so they allow the OS systems to fully start before coming online.

0 Kudos
Reply
matthewfry
Navigator

All of the Watchdogs seem to be installed by default as Automatic.. these services seem to be the main culprits.

0 Kudos
Reply
ranjith_koppu
SailPoint Employee
SailPoint Employee

@matthewfry - Were you able to address this issue by making the WatchDog services startup type to "Automatic Delayed Start" ? By default, FAM sets the services that depend on other services to be on delayed start and all other services to start automatically.

I have heard from some customers that the services are not reported as running in the health center due to the fact that the servers don't follow a particular order while patching. If some dependent services are down, I have seen scenarios where FAM doesn't report the status or perform status properly until the services are stopped and started in the prescribed order.

I haven't heard that services won't start after a patching. It might be something to do with the server itself. I would check the Event Viewer and other related logs to analyze why these services don't come up automatically.

 

Regards,

Ranjith 

0 Kudos
Reply
matthewfry
Navigator

Its definitely not a local server issue, as it happened to at least 25 different servers.  I have noticed this a lot in the past, that for some reason the Watchdog service tends to not start after a reboot.  This also happens with my Event Managers, which are set to automatic as well.  I will go through and try to set them all to delayed and see what happens... but that will take me some time as I have many of them.

0 Kudos
Reply
matthewfry
Navigator

By the way everyone, I discovered the issue here.  Windows has a default setting in the registry where if a service takes longer than 30 seconds to start, it will error out.  Well, these services are taking longer than 30 seconds to start.  I changed that default setting in the registry to 180 seconds, and now my services start up automatically without isse.

I am a bit curious why it takes so long for these services to start though.

0 Kudos
Reply
shivganesh
Sailor

@ranjith_koppu  Could you please let us know what is the exact path to change the windows registry key settings only specific to FAM application Services so that 180 seconds setting can be configured as mentioned above?

0 Kudos
Reply
ranjith_koppu
SailPoint Employee
SailPoint Employee

@shivganesh 

Follow the below steps.

  1. Launch Windows Registry Editor.
  2. Find the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. Right-click this key and select New DWORD (32-bit) Value.
  4. A new value namedNew Value #1 appears on the right.
  5. Change the name of this new value to ServicesPipeTimeout.
  6. Right-click the ServicesPipeTimeout value you created, and choose Modify. The Edit DWORD Value window opens.
  7. Change Base to Decimal.
  8. In the Value data field, type the value (in milliseconds) of time allowed for the service to start, and click OK.

  9. Finally, restart the machine.

Regards,

Ranjith

0 Kudos
Reply