IIQ 8.2p2 and Aurora RDS MySQL -- max_allowed_packet errors

We are running IdentityIQ 8.2p2 with Aurora RDS as our backend database. We’ve recently started receiving errors while running our new hires process saying:

Parameter of prepared statement which is set through mysql_send_long_data() is longer than ‘max_allowed_packet’ bytes

Typically, this can be resolved by upping the max_allowed_packet value, which I’ve done.  I’ve set this to the highest value possible (1GB) and we still get this error.  All of my digging leads me to believe this is somehow related to the size of the LOBs that SailPoint is trying to set on a record in the DB, but I’m unable to get any further in my diagnosis.  Has anyone run into this issue before?  Any advice on how to pin down the problem?

hey  @sdnakhla  Im running into the same error.  Were you able to resolve this?

In our case it was due to data corruption increasing the size of the role name and description to ridiculous proportions.  The database encoding was not set to UTF-8 and characters that were copy-pasted from Microsoft Word into role descriptions were being mangled.  Each time the data was read and written to the DB it would double in size, so we had roles that were hundreds of MBs in size.  Once we corrected that the errors disappeared.