cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IdentityIQ identity refresh hangs when run in sequential task

IdentityIQ identity refresh hangs when run in sequential task

Symptoms

When an identity refresh is run as part of a sequential task, it hangs and does not complete as expected.

 

Diagnosis

Most users should find a sequential task as described above completes successfully. A small subset of users may find the task hangs or fails to complete when these tasks are schedule sequentially. Within the subset of failure cases, most errors are reported when the identity refresh takes places immediately after an account aggregation. Since account aggregations may prompt their own refresh activities which can lock the identity during processing, there is potential for a sequentially scheduled refresh to encounter errors during the task.

 

Solution

A user encountering errors in this situation should try separating the aggregation and refresh tasks into discrete tasks, scheduled at different times. This has proven to resolve many instances where a sequentially scheduled identity refresh failed to complete.

Labels (1)
Version history
Revision #:
4 of 4
Last update:
‎May 16, 2026 11:55 AM
Updated by: