Showing results for 
Show  only  | Search instead for 
Did you mean: 

Quick setup for the Deployment Accelerator in Eclipse notes

Quick setup for the Deployment Accelerator in Eclipse notes

This tool is not supported by SailPoint. Please be aware of the risks when using the tool. If you have any questions, please ask in the IdentityIQ Forums.



Deployment Accelerator setup

1. Install Eclipse

2. Create project

3. In your Eclipse, navigate to Help->Install New Software

4. Add Repository: Name = .... , Location:

5. Click Ok. Now, from the 'Work with' dropdown, select IdentityIQ Deployment Accelerator

6. Check the box next to the Feature, and click 'Next'. Review the item and click 'Next' again, Accept the terms of the agreement, and click 'Finish' (You will need to accept that the software contains unsigned content, and restart eclipse)

7. Import the "Workflow-Importer.xml" workflow object into your IdentityIQ instances at

8. To create a new IdentityIQ project, start by selecting File -> New Project. This brings up the New Project wizard. In the wizard, select the "IdentityIQ Project" option from the "SailPoint" folder

9. Add referenced libraries by clicking the right click on the project folder, then click properties and add the external jar from the webapps-identityiq-WEB-INF-lib and Select

10. Now, import the object from IIQ creating folder as object name and click right click on folder and click the import artifact and choose the object you want to import

11. Then, start work with the object and after you finished, just right click on eg. .xml file and then deploy Artifact in the target IIQ server


Deployment Accelerator assets

This tool is not an officially supported SailPoint product and is made available free of charge, with no support agreement, for the benefit of the implementer community.

Labels (2)

In the project properties/IdentityIQ Project Properties, I recommend changing the "Connection timeout (ms)" to something like 25000.  This saved me some headache with connectivity errors.

Question for the folks involved in developing the Deployment Accelerator.  This is really kind of about Eclipse, but it has implications for the Deployment Accelerator, I think.

I just installed the Deployment Accelerator into Eclipse 2019-09 R (4.13.0), and discovered that the Navigator is now marked as "Deprecated".  This is an Eclipse issue, and a little research indicates that Eclipse is planning to remove the Navigator view in future versions.  My problem is that I have never seen the Deployment Accelerator function correctly in any other view than Navigator.  I'm wondering, and asking, whether I've done something wrong that leads me to conclude that, if the answer to that is "no", what the Deployment Accelerators plans are for it when "Navigator" is removed from Eclipse. 

After completing sailpoint project in eclipse successfully and tried to get the Application objects using import Artifact option, it is giving server side error. Some exception "DashboardContent" class not found.

Hi @v764681 

Please try How to Configure Deployment Accelerator in IIQ 8.0 - Compass (

It might solve your problem


Hi @hardikmehta

Thanks for your soluiton. Actually in sailpoint 8 there is a Dashborad feature which was there earlier versions but not in version 8. So I unchecked  those options  from :

preferences -> identityiQ preferences-> identiyiQ import preferences -> uncheck  Dashborad Layout, Dashboardcontent, Identity Dashboard. ->  apply.



projectcommunicate vividlyMore (Definitions, Synonyms, Translation)





Happy to help! 

Following the installation instructions, I am not getting the "Import Artifact" option while right clicking on the config folder.

Eclipse Photon
IdentityIQ 8.1p1
Tried both 4.0 and 4.02 of the Deployment

Thoughts anyone?

Getting errors with offline installation

Version history
Revision #:
6 of 6
Last update:
‎Mar 16, 2023 12:18 PM
Updated by: