After upgrade, provisioning and aggregation from IQService stopped working
Symptoms
Following an upgrade, provisioning operations and aggregation through the Active Directory or other connectors stop working.
Diagnosis
Several connectors, including the Active Directory connector, rely on the windows agent IQService. The version and patch level of the IdentityIQ server and the IQService agent must match exactly. If the IQService and IdentityIQ server version are out of sync, connectors relying on the IQService will not work and provisioning and aggregation will fail.
It is important to note that in many deployments, there can be multiple copies of IQService running on various servers.
To verify the version of your IdentityIQ server, run the command "about" from the IdentityIQ console and note the version:
> about
Version: 8.0 31069ce-20190529-143133
To verify the version of an IQService instance, run the "IQService -v" command from command line on every server running IQService:
C:\SailPoint\IQService>IQService -v
Build version: 6.3p2 r3cbace3-20140916-123153
Alternatively, if IQService logging is enabled, the IQService version will be listed in the log file:
09/26/2019 13:52:07 : ServiceMain [] DEBUG : "
Build version: 6.3p2 r3cbace3-20140916-123153
Solution
- Ensure the IdentityIQ server is running the correct version and patch level for your deployment.
- Identify all servers running the IQService agent.
- Stop the IQService on each server.
- On the IdentityIQ server, copy the contents of the ".../WEB-INF/bin/win/" directory to all locations where IQService was running.
- Restart each instance of IQService.
- Verify the version and patch level of each instance of IQService now matches the version and patch level of IdentityIQ.
- Mark as Read
- Mark as New
- Bookmark
- Permalink
- Report Content to Moderator
7.2 p4