cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error message: "The server is unwilling to process the request"

Error message: "The server is unwilling to process the request"

 

Product

All IdentityIQ product versions can show this error since the error comes from Active Directory.

 

Environment

Active Directory

 

Error

You may find one or more of the below in the logs:

 

"Error occurred while setting password for the account. Exception has been thrown by the target of an invocation.The server is unwilling to process the request. (Exception from HRESULT: 0x80072035)"

 

Failed to update attributes. The server is unwilling to process the request.

 

ERROR : "Caught exception in Modify. The server is unwilling to process the request."

 

Root Cause

The error is not caused by IIQ, but comes directly from Active Directory.   This error may be returned by Active Directory by any one of these problems:

  • An attempt to violate a password policy, such as history, password length, blank password, etc.
  • An attempt to set a value for an attribute that does not exist
  • An attempt to set an incorrect value for an attribute (the value does not adhere to the attribute's syntax).
  • Any other operation that the Active Directory server will not allow.

 

Workaround/Fix

Ensure that the operation is allowed by Active Directory: passwords should comply with password policy; attributes must exist; attribute values must adhere to the attribute's syntax.  Also check network metrics for anomalies and check network security appliances for closed connections.

Version history
Revision #:
3 of 3
Last update:
‎May 16, 2026 11:44 PM
Updated by:
Sally_Newton