IdentityIQ Console - Out of memory error
Symptoms
Performing an action via IIQ Console results in an "Out of memory" error. This occurs when the virtual machine running the IIQ Console application has exceeded the allocated memory.
Diagnosis
IIQ Console is configured by default to allocate a minimal amount of memory, ideal for demonstrations and proof-of-concept installations. If you intend to use IIQ Console for administrative or production/support tasks, you will need to allocate more memory.
Solution
The memory allocation settings for IIQ Console are defined in the file WEB-INF/bin/iiq
or WEB-INF/bin/iiq.bat.
To adjust the allocated memory:
- Open the
WEB-INF/bin/iiq
orWEB-INF/bin/iiq.bat
file in your preferred text file. - Locate the
JAVA_OPTS
parameter, near the top of the file, approximately line 16. - Edit the parameter definition to be
JAVA_OPTS="-Xms128m -Xmx1024m -XX:MaxMetaspaceSize=384m -Dsun.lang.ClassLoader.allowArraySyntax=true -Djava.awt.headless=true"
- Save the file and start IIQ Console.
- If you continue to see "Out of memory" errors, adjust the maximum memory allocated by increasing the value specific in the
-Xmx
flag.
Additional info
For more information about improving the performance of the Java Virtual Machine in IdentityIQ, refer to Java JVM Memory Tuning Guide for IdentityIQ
For information about using IIQ Console in the course of performing IdentityIQ upgrades, refer to Upgrade: iiq console Memory Heap Allocation Settings
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cool stuff!!! I was getting similar error in iiq console.
Thanks,