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Why do I get null pointer in method invocation error?

Why do I get null pointer in method invocation error?

 

Product

IdentityIQ

 

Environment

All

 

Error

Null pointer in method invocation BSF info: <RULE NAME> at line: 0 column: columnNo

 

Root cause

The rule indicated by this error message is incorrect.This is due to incorrect coding or using a rule that has deprecated method in it. Fortunately, BSF directs you to the cause of the exception. After the colon and before the word"at", you will see the name of the custom coded rule which causes this error message. Here, I inserted <RULE NAME> as an example.

 

Workaround/Fix

IdentityIQ Support team is unable to support the various, site specific custom coded rules. There is an Expert Services Group that does such work, which can be contracted by asking your Account Manager to assist you in gaining a resource.

This debugging article should assist you in quickly finding the root cause of your rule error:

Debugging rules

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Comments

As an addendum, I've also seen this occur with an out-of-the-box rule- Account Report Form Customizer.

I helped a customer who was running a report using this rule and contained within the rule is a line of code that references the Link ObjectConfig-

ObjectConfig linkConfig = ObjectConfig.getObjectConfig(Link.class);

The Link ObjectConfig was missing from their environment which was causing a NULL Pointer Exception identical to the one above.

This link broken or something - Debugging rules

We are facing the same issue and wanted access the above link to get any reference but the link is not working...

Is this can be fixed? so that we can refer..

Version history
Revision #:
2 of 2
Last update:
‎Aug 02, 2023 08:31 PM
Updated by:
 
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